vSphere Client连接ESX时提示: "clients.xml"文件时出错的解决方法

最近数据中心环境总是错误不断,虚拟化这东西水有点深啊,今天的问题是:
vSphere Client在连接ESX时出错系统提示:
分析 点出确定后继续报错:
这时我再点击确定后又出现如下错误:
VirtualInfrastructure.Utils.HttpWebRequestProxy的类型初始值设定项引发异常

问题分析:

产生这个问题的原因如下:vSphere 4.0以及更早版本是基于DotNet 2.0框架的,而微软于2010年6月9日对DotNet框架作了一次补丁更新(KB980773),两者之间产生了不兼容。由于Windows 7下的DotNet版本是3.5,所以在Windows 7上安装使用vSphere Client 4.0也会产生这个错误。

解决方案:

1、卸载KB980773更新
2、将vSphere Client更新至4.0 Update 1以上版本,只要确保vSphere Client的Build号不低于208111就行,
下载更新包的地址见下:(这个可能要许可否则不能下载)
http://downloads.vmware.com/d/info/datacenter_downloads/vmware_vsphere_4/4
注意:为避免增加工作量,这里友情提醒一下这里的升级并不需要升级整个vSphere套装,只要单独升级vSphere Client就可以解决方案。

weinxin
DC Farm小程序二维码
扫一扫添加博客小程序
Jim

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: